Some checks are pending
ci/woodpecker/pr/ci Pipeline is pending
An experiment to see if we can minimize the PatOS project even further, and not have to adapt NixOS packages and config for our needs.
16 lines
423 B
Nix
16 lines
423 B
Nix
{ pkgs, ... }:
|
|
let
|
|
version = "6.13.2";
|
|
in
|
|
pkgs.linuxPackagesFor (
|
|
pkgs.linuxManualConfig {
|
|
version = "${version}-patos1";
|
|
modDirVersion = version;
|
|
src = pkgs.fetchurl {
|
|
url = "https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-${version}.tar.xz";
|
|
hash = "sha256-zfYpgZBru+lwGutzxPn8yAegmEbCiHMWY9YnF+0a5wU=";
|
|
};
|
|
configfile = ./generic.config;
|
|
allowImportFromDerivation = true;
|
|
}
|
|
)
|