17 lines
258 B
Nix
17 lines
258 B
Nix
{
|
|
runCommand,
|
|
pkgs,
|
|
|
|
}:
|
|
|
|
runCommand "patagia-certs"
|
|
{
|
|
buildInputs = with pkgs; [
|
|
openssl
|
|
];
|
|
|
|
}
|
|
''
|
|
mkdir -pv $out
|
|
openssl req -new -x509 -days 365 -nodes -out $out/cert.pem -keyout $out/key.pem -subj "/CN=patagia-signing"
|
|
''
|